booxi status

Booxi minor software update [EU/2026-09-22] from 2026-09-22 14:00 EDT to 2026-09-22 17:00 EDT

Scheduled maintenance Booxi Europe - Software updates
2026-09-22 14:00 EDT · 3 hours

Updates

Scheduled

Dear clients,

An upcoming Booxi software update will be performed without service interruption and will contain the following improvements:

In the Booking Widget (v3):

  • Additional attendees on group bookings made through Book Now now receive their confirmation emails.

In the Back Office:

  • Resolved an issue where updating or cancelling a client-booked queue appointment from the Back Office triggered a consent recording error.

In the Booxi API:

  • Creating a service through the Booking API without a request body now returns a clear validation error instead of a server error.

In the Booxi platform:

  • Resolved failures and timeouts when multiple customers simultaneously booked group events that share the same staff member.
  • Resolved timeouts that could occur when creating group events or closing appointments while billing processing was running.
  • Webhook deliveries that return any 2xx success code, such as 202 Accepted, are now treated as successful and are no longer retried.
    Sincerely,

Booxi support team

September 15, 2026 · 11:55 EDT

← Back