booxi status

Booxi minor software update [US/2026-07-29] from 2026-07-29 13:00 EDT to 2026-07-29 16:00 EDT

Scheduled maintenance Booxi North America - Software updates
2026-07-29 13:00 EDT · 3 hours

Updates

Scheduled

Dear clients,

An upcoming Booxi software update will be performed without service interruption and will contain the following improvements:

In the Booking Widget (v3):

  • The Book Now widget can now open automatically when a visitor arrives from a URL that includes the booknow-widget-action=open parameter.

In the Back Office:

  • Resolved an issue where staff could not open the details of a resource’s weekly availability schedule.

In the Booxi platform:

  • Resolved errors that could occur when editing or re-cancelling a queue appointment that had already been cancelled or marked as no-show.

Sincerely,

Booxi support team

July 27, 2026 · 16:42 EDT

← Back