booxi status

Booxi minor software update [EU/2026-07-28] from 2026-07-28 14:00 EDT to 2026-07-28 17:00 EDT

Scheduled maintenance Booxi Europe - Software updates
2026-07-28 14:00 EDT · 3 hours

Updates

Scheduled

Dear clients,

An upcoming Booxi software update will be performed without service interruption and will contain the following improvements:

In the Back Office:

  • The Back Office queue list is now sorted by status priority by default, so staff see clients who need attention first.
  • Back Office search now responds faster, including when fetching reservations and their attendees.

In the Booxi API:

  • The PUT Booking API can now reschedule a resource-based appointment and automatically assign an available resource for the new time slot.
  • The Search Availability API now applies the requested time interval to every page of paginated results, not just the first.

In the Booxi platform:

  • Resolved an error that could prevent merchants from opening or creating a new queue when past queue appointments were still being closed.
  • A new Booking Rules setting lets brands trigger queue auto-assign as soon as a client reaches the front of the line, without waiting for staff to mark them as arrived.
  • Open queue entries are now automatically completed when the queue closes, so they no longer linger on the staff calendar or distort serve-rate reporting.
  • Resolved an issue where valid phone numbers from French overseas regions such as Guadeloupe and Réunion were incorrectly rejected during booking.
  • Multi-service queue entries now occupy their full combined duration on the staff calendar to prevent double-booking, and shrink to the actual time served once completed.
  • A sales associate’s open queue entry is now completed automatically when they are assigned to a new client, keeping queue data and serve-rate accurate.

Sincerely,

Booxi support team

July 20, 2026 · 17:19 EDT

← Back