booxi status

Booxi minor software update [EU/2026-07-14] from 2026-07-14 14:00 EDT to 2026-07-14 17:00 EDT

Scheduled maintenance Booxi Europe - Software updates
2026-07-14 14:00 EDT · 3 hours

Updates

Scheduled

Dear clients,

An upcoming Booxi software update will be performed without service interruption and will contain the following improvements:

In the Back Office:

  • Resolved an error that could occur when importing a staff calendar in the Back Office.
  • Staff who are past their office hours no longer appear as available in the queue staff assignment drop-down.
  • Services created with the older spacing format now display their spacing and duration correctly.
  • Queue entries are now color-coded by status, making it easier to scan the queue at a glance.
  • Fixed an issue where an unassigned resource still appeared selected in a queue appointment’s details, causing it to be reassigned when saving other changes.
  • Client phone and mobile fields now include an international country picker that sets the dialing code and expected number format for each country.

Sincerely,

Booxi support team

July 6, 2026 · 17:16 EDT

← Back