booxi status

Booxi minor software update [EU/2026-02-25] from 2026-02-25 14:00 EST to 2026-02-25 17:00 EST

Scheduled maintenance booxi Europe - Software updates
2026-02-25 14:00 EST · 3 hours

Updates

Scheduled

Dear clients,

An upcoming Booxi software update will be performed without service interruption and will contain the following improvements:

In the Back Office:

  • Added a queue icon to completed queue bookings in the Calendar tab; the icon is also displayed when hovering a queue booking.
  • Fixed an issue causing code elements to appear incorrectly in the Alerts section when the language was set to Arabic.
  • Fixed an issue where the “Assign Personnel” window for queue bookings appeared off-screen when the language was set to Arabic.
  • Updated the text shown in the cards search infobox.
  • Updated the text shown in the queue search infobox.
  • Fixed an issue causing survey previews to have incorrect elements and sizing.

This software update won’t affect your operations.

Sincerely,

Booxi support team

February 23, 2026 · 11:11 EST

← Back