booxi status

Booxi minor software update [EU/2025-11-12] from 2025-11-12 14:00 EST to 2025-11-12 17:00 EST

Scheduled maintenance booxi Europe - Software updates
2025-11-12 14:00 EST · 3 hours

Updates

Scheduled

Dear clients,

An upcoming Booxi software update will be performed without service interruption and will contain the following improvements:

This software update won’t affect your operations.

In the Back Office:

  • Bookings that were previously assigned to deleted staff can now be updated or reassigned as needed. This ensures no booking gets stuck due to staff record changes.
  • [Queueing] During queue setup, only staff members who offer queue services will now appear in the configuration list, simplifying setup and preventing selection errors.
  • Updated the icons in the queue context menu to better reflect each action, making them more intuitive and easier to recognize at a glance.

In the Head Office:

  • In the Analytics tab, removed two decimals from the “Share of Completed Appointments” column in the “Top Performing Stores” tab to improve data readability.

In the Booxi platform:

In the booking widget:

  • Updated the service preselection behavior in the case of multi-service booking: initially, when adding an additional service, the previously selected service remained selected. Now, no service is pre-selected, the list starts from the top, and previous selections are cleared.

Sincerely,

Booxi support team

November 10, 2025 · 13:45 EST

← Back