booxi status

Booxi incident [US/2025-06-12]

Major incident booxi North America outages
2025-06-12 14:25 EDT · 2 hours, 52 minutes

Updates

Resolved

Dear clients,

The issue is now resolved. The issue was caused by a Google Cloud services outage; we are monitoring the situation for any changes.

Again, we are sorry for any inconveniences this may have caused you.

Booxi team

June 12, 2025 · 17:06 EDT
Issue

Dear clients,

We are currently experiencing an issue that is preventing users from logging in to the Booxi platform. The issue is related to a major Google outage happening currently.

We are investigating, and will let you know as soon as Booxi is back up and running.

We are sorry for any inconveniences this may have caused you.

Booxi team

June 12, 2025 · 14:27 EDT

← Back