booxi status

Booxi incident [EU/2025-06-07]

Major incident booxi Europe outages
2025-06-07 22:24 EDT · 1 hour, 31 minutes

Updates

Issue

Dear clients,

We had an issue with the Back Office login, which has been fixed. If you have issues to login, please try again. If the problem persist, please contact us.

We continue to monitor the situation which started at 10:24 PM EDT and was fixed at 11:55 PM EDT.

We are sorry for any inconvenience this may have caused you.

Booxi team

June 8, 2025 · 00:09 EDT
Issue

Dear clients,

We are currently experiencing failures on the Back Office login. If you have issues to login, please try again. If the problem persist, please contact us.

We are working on this issue which started at 22:00 PM EDT for which we applied fixes, but we continue to monitor the situation.

Again, we are sorry for any inconvenience this may have caused you.

Booxi team

June 7, 2025 · 23:27 EDT

← Back