booxi status

Booxi incident [US/2025-05-20]

Major incident booxi North America outages
2025-05-20 11:53 EDT · 12 minutes

Updates

Resolved

Dear clients,

We have addressed the issue, and it is now resolved.

The issue occurred between 11:18 AM EDT and lasted until 11:45 AM EDT.

Again, we are sorry for any inconvenience this may have caused you.

Booxi team

May 20, 2025 · 12:02 EDT
Issue

Dear clients,

The Booxi Back Office is currently unavailable; we are working on resolving it as soon as possible.

We will keep you updated of any change. We are sorry for any inconvenience this is causing you.

Booxi team

May 20, 2025 · 11:53 EDT

← Back